Gift Cards Email Delivery Issue
Incident Report for Shetewy Pay
Resolved
The issue is now resolved. We added an extra $25.00 credit to the affected users as an apology for the latency that occurred. Contact go@shetewypay.com for any further inquiries.
Posted Feb 06, 2021 - 07:46 UTC
Monitoring
A fix has been implemented. Email delivery delay occurred for less than 80 minutes, If you recently purchased a gift card and did not receive it via email, you will receive it again in a few minutes.
Posted Feb 06, 2021 - 07:45 UTC
Investigating
We are currently experiencing issues with the email delivery of purchased gift cards, being sent from giftcards@shetewypay.com. The Shetewy Pay team is investigating that in the meantime. If you recently purchased a gift card and have not yet received card information yet, please email go@shetewypay.com. We will provide an update as soon as we know more. The scope of any customer impact has not been determined at this time.
Posted Feb 06, 2021 - 06:58 UTC