Issue with Credit Card Payments
Incident Report for Shetewy Pay
Resolved
This incident has been resolved.
Posted Apr 10, 2021 - 15:20 UTC
Investigating
We are currently experiencing issues with all payments submitted using credit or debit cards. As a result, your attempts to top up your e-wallet or pay merchants using your direct credit or debit card may not be successful. The issue should be resolved in a 20 minutes time frame. We sincerely apologize for the inconvenience.
Posted Apr 10, 2021 - 15:06 UTC
This incident affected: Service API and Account (Top-up Gateways).