Emergency unscheduled maintenance
Incident Report for Shetewy Pay
Resolved
The incident has been resolved. All our services are up and running. Please contact us via Live Chat if you have any inquiries or questions, or contact go@shetewypay.com. Thank you for your understanding.
Posted Feb 12, 2021 - 12:12 UTC
Update
Shetewy Pay's website is currently undergoing unscheduled maintenance to upgrade our systems in order to better serve you. Due to this, it may not be available and show a 502 or 522 error. Also, it may not be possible to sign in or access some pages on your account. We apologize for any inconvenience and thank you in advance for your patience and understanding.
Posted Feb 12, 2021 - 12:00 UTC
Investigating
Shetewy Pay's website is currently undergoing unscheduled maintenance to upgrade our systems in order to better serve you. Due to this, it may not be available and show a 502 or 522 error. Also, it may not be possible to sign in or access some pages on your account. We apologize for any inconvenience and thank you in advance for your patience and understanding.
Posted Feb 12, 2021 - 11:59 UTC
This incident affected: Account (Login) and Management Portal.