PayNow URL Unavailable
Incident Report for Shetewy Pay
Resolved
This incident has been resolved. You can resume sending payment requests from your account.
Posted Feb 05, 2021 - 07:24 UTC
Investigating
The Shetewy Pay team is investigating the availability of PayNow URLs sent through invoices submitted by users. We will provide an update as soon as we know more. The scope of any customer impact has not been determined at this time.
Posted Feb 05, 2021 - 07:16 UTC