Service Blockage for Libya-based Accounts
Incident Report for Shetewy Pay
Resolved
We’re continuing to limit number of services for Libyan accounts and some other account functionalities until we receive the proper service license to provide services to individuals in Libya. We will announce that once is completed and ready.
Posted Dec 05, 2020 - 12:01 UTC
Identified
A number of services were blocked for Libya-based accounts. For more information, please read the service announcement from https://shetewypay.com/announcement-about-service-in-libya
Posted Oct 25, 2020 - 20:33 UTC